Cara Mencegah Serangan Brute-force di Mikrotik

Cara Mencegah Serangan Bruteforce di Mikrotik

DailyBlog.id - Serangan brute force adalah upaya mendapatkan akses sebuah akun dengan menebak username dan password yang digunakan. Brute force attack sebenarnya merupakan teknik lama dalam aksi cyber crime. Namun, masih banyak digunakan karena dianggap masih efektif. Dalam hal ini untuk melakukan penyerangan pada mikrotik agar pelaku mendapatkan akses login ke mikrotik.

Agar mencegah seseorang melakukan bruteforce pada mikrotik dan menjadikan router mikrotik agar aman dari serangan tersebut, kalian bisa membaca tutorial dari artikel ini secara lengkap.

Di tutorial kali ini yang dicegah dari sertangan bruteforce yaitu:

  • FTP
  • SSH

Untuk mencegah dari serangan bruteforce, kalian dapat memanfaatkan firewall pada mikrotik. Oke langsung saja ke cara mencegahnya.

Mengamankan FTP

Dalam kasus pertama, kalian mencoba untuk mengamankan FTP dari serangan bruteforce. Dan kalian bisa dengan cara buka New Terminal lalu copy script yang ada di bawah ini.

/ip firewall filter
add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect"
address-list=ftp_blacklist address-list-timeout=3h


Mengamankan SSH

Dalam kasus kedua, kalian mencoba untuk mengamankan SSH dari serangan bruteforce. Dan kalian bisa dengan cara buka New Terminal lalu copy script yang ada di bawah ini.

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no


Dengan konfigurasi diatas, maka ketika ada client yang mencoba meremote Router melalui SSH dan mengalami gagal login selama lebih dari 3 kali, maka alamat IP penyerang akan di drop selama 10 Hari.

Nah itu dia cara untuk mengamankan dari serangan bruteforce pada mikrotik. Kalian bisa mengkonfigurasi sesuai dengan kebutuhan kalian. Semisal mengganti port yang mau diamankan atau mengganti lama hari ip addr yang didrop, dll.

Mungkin cukup sekian artikel dari saya, semoga artikel yang saya berikan ini dapat bermanfaat bagi kalian semua. Jika saya ada salah kata, saya mohon maaf. Sekian dan terima kasih.

Selamat mencoba!...

Posting Komentar (0)
Lebih baru Lebih lama